Ruby Supported Versions

Ruby Supported Components

Supported Versions

Ruby Versions
MRI Ruby >= 2.1
Frameworks Versions Note
Cuba >= 3.0.0
Padrino >= 0.12.0
Roda >= 2.0.0
Action Controller Rails 4+5
Ruby on Rails >= 3.2 ActionController & ActionView Partial rendering insights
ActiveRecord >= 3.2 MySQL, MySQL2, PostGIS & PostgreSQL Adapters
ActionView with layout and template rendering visibility
Rack >= 1.4.5
Rails LTS >= 2.3 Basic request visibility
Rails API >= 0.4.0
Sinatra >= 1.1.4
Client Versions Note
Net::HTTP >= 2.1
Excon >= 0.21.0
Faraday >= 0.7.6 with supported Net::HTTP or Excon Adapters
GRPC >= 1.0.1
HTTParty via Net::HTTP
HTTP-Requestor > 1.0.0
RestClient >= 1.6.0
Memcache Versions
Dalli >= 2.0.0
Messaging & Background Job Processing Versions
Resque >= 1.22.0
Sidekiq >= 2.12.0

Supported Webservers

  • Apache
  • Nginx
  • Passenger
  • Puma
  • Rhebok
  • Thin
  • Unicorn

Sensor Data Collection

Tracked Configuration Metrics
Ruby Version Time Spent in GC
Runtime Arguments Memory Usage
Framework Heap Slots
Gem Bundle Threads

Tracing

Mode

See Also